Additionner des chiffres, des mots et des cellules vides avec Excel

Sous Excel, les formules les plus simples sont souvent celles qui vous font perdre du temps. Découvrez comment additionner des chiffres, des mots, des cellules vides… 

Activ’Formation | Excel | Additionner des nombres, des mots, des cellules vides


Additionner en colonne, en ligne et en bloc

Sélectionner les valeurs + cliquer sur l’icône Somme automatique å (onglet Accueil, groupe Editions, icone å ).

L’astuce fonctionne dans tous les sens, la somme s’affiche juste après les cellules sélectionnées

Additionner excel en un clic

Pour additionner des cellules ou des plages de cellules qui ne se touchent pas : 1re sélection (d’une cellule ou plage), touche [Ctrl] enfoncée sans la relâcher, clic sur les autres cellules ou plages de cellules (les sélections sont grisées pour vous guider). Ensuite, clic sur l’icône å.

Bien sûr, vous pouvez aussi écrire la formule =somme( etc. Mais ici, en un clic, tout est dit.


Compter le nombre de fois où Excel rencontre « un mot » (ou un groupe de mots)

La formule : =NB.SI(plage;critère)

Plage = plage des cellules à observer (ici de B2 à B10).

Critère = mot(s) à observer (ici Excel 1 visible en cellule D2).

Additionner excel mots nb si

Pour pouvoir recopier la formule (ici =NB.SI(B2:B10;D2) vers le bas, il faut bloquer la plage de cellules. Pour cela, ajouter le signe $ de cette façon directement dans la barre de formule : $B$2:$B$10. Ensuite, recopier la formule vers le bas.

Bien sûr, il existe d’autres méthodes et on pourrait ajouter des tas d’explications. Mais à ce stade, votre objectif est d’obtenir le résultat attendu sans « vous prendre la tête ».


Compter des cellules non vides

La formule : =NBVAL(valeur1;[valeur2])

Valeur1;[valeur2] : cellule ou plage de cellules (ici A2:A10).

Dans l’exemple ci-dessous, 9 salariés doivent exprimer leurs vœux de formation.

Excel additionner mot formule nb val


Compter des cellules restées vides

La formule : =NB.VIDE(plage)

Plage : plage de cellules (ici B2:B10).

Dans l’exemple ci-dessous, 4 salariés (sur 9) n’ont pas exprimés leurs vœux de formation.

Additionner du vide excel nb vide


Pour aller plus loin

SI EST VIDE, une formule Excel magique

Excel : cumuler des données entre tableaux avec la fonction consolider

Pourcentages de répartition et d’évolution sous Excel sans prise de tête