Effectuer une somme conditionnelle avec la fonction DECALER

Sous Excel, la fonction DECALER permet de récupérer une plage de cellules de dimension variable dans une formule. Associée à la fonction SOMME elle peut effectuer un cumul sous condition. Prêt/e à découvrir une nouvelle façon d’additionner vos données ? GO !

Formation express | Excel | Associer les fonctions SOMME et DECALER


Découvrir la fonction combinée conditionnelle =SOMME(DECALER

Dans cet exemple, la formule =SOMME(DECALER(B2;0;0;D2;1)) visible en D6 calcule la valeur totale d’une plage de cellules couvrant 2 lignes situées dans la colonne B (CA). Si la valeur 2 est remplacée par 3 dans la cellule D2 (nombre de mois), Excel va décaler la plage de référence (colonne B) vers le bas et inclure le CA de mars, et ainsi de suite.Somme DECALER activassistante

Décryptage de la formule

Les arguments de la fonction =SOMME(DECALER(réf;lignes;colonnes;[hauteur];[largeur])) sont les suivants :

  • SOMME calcule la somme de la plage demandée (ici, de la cellule B2 à B13).
  • DECALER indique à Excel qu’il doit adapter la plage à cumuler en fonction d’une valeur qui va lui être indiquée (ici, valeur 1 à 12 saisie dans une liste déroulante reliée à la cellule D2).
  • Réf est la cellule ou plage de cellules adjacentes par rapport à laquelle le décalage doit être effectué (ici, B2, correspondant au CA du mois 1).
  • Ligne est le nombre de lignes vers le haut ou vers le bas dont la cellule supérieure gauche de la référence renvoyée doit être décalée. L’argument peut être nul (zéro), positif (c’est-à-dire à droite par rapport à la référence de départ), ou négatif (c’est-à-dire à gauche de la référence de départ). (Ici, la valeur est nulle, donc zéro).
  • Colonne est le nombre de colonnes vers la droite ou vers le gauche dont la cellule supérieure gauche de la référence renvoyée doit être décalée. L’argument peut être nul (zéro), positif (c’est-à-dire à droite par rapport à la référence de départ), ou négatif (c’est-à-dire à gauche de la référence de départ). (Ici, la valeur est nulle, donc zéro).
  • [hauteur] est la hauteur, exprimée en nombre de lignes, attendue pour le résultat. Elle est égale à Réf si omise. (Ici, elle correspond à la cellule qui contient le nombre de lignes indiqué dans la cellule D2)
  • [largeur] est la largeur, en nombre de colonnes, attendue pour le résultat. Elle est égale à Réf si omise. (Ici, elle correspond au nombre de colonne où se trouvent les données à cumuler, c’est-à-dire 1 colonne).

Autres ADDITIONS ? Autres tutos… GO !

  • Excel : cumuler des données entre tableaux avec la fonction consolider Lire
  • Additionner des chiffres, des mots et des cellules vides avec Excel Lire
  • Excel : calculer des dates, des délais d’échéance et alerter Lire
  • Saisir et calculer des heures sous Excel Lire
  • Suivi des factures : gérer les retards de paiement sous Excel (découvrir somme.si) Lire

Autre fiche en lien avec cet article

  • Créer des listes déroulantes sous Excel Lire