SI EST VIDE, une formule Excel magique

Sous Excel, la recopie d’une formule qui fait référence à une cellule vide provoque l’affichage d’un résultat nul ou l’apparition d’un message d’erreur. Or, la formule est JUSTE ! Pour éviter ce problème, découvrez la formule SI EST VIDE.

Interdire l’affichage d’un résultat quand il fait référence à une cellule vide

Dans le visuel ci-dessous, en cellule D3, une formule classique (C3/B3) a été appliquée puis recopiée vers le bas.

Dans les cellules qui font références à des cellules vides, Excel affiche un résultat nul (D6, D7 et D8).

EXCEL_si_est_vide_1Utiliser la fonction SI EST VIDE d’Excel

En colonne E (cf. visuel ci-contre), la fonction SI EST VIDE a été ajoutée devant la formule initiale = (C3/B3).

Pour l’appliquer, suivre le raisonnement de toute fonction conditionnelle (à savoir : SI… ALORS… SINON) et la combiner avec la fonction ESTVIDE.

Ce qui donne, en E3, la formule :

=SI(ESTVIDE(C3);″ ″;C3/B3).

Pour lire la formule, utiliser le raisonnement SI ALORS SINON. À savoir : « SI le contenu de la cellule C3 EST VIDE ALORS rien (matérialisé par des guillemets ″ ″)SINON appliquer la formule C3/B3».

En E6, E7 et E8, la formule est visible sur la barre de formule, mais les cellules sont vides car C6, C7 et C8 le sont aussi.

En résumé, si les cellules sont vides, Excel affiche du vide, sinon, il affiche le résultat.